Go get scope_out - it should be in core!

Posted by Tom on 2007-04-03

The scope_out plugin is such a great extension to ActiveRecord I can’t imagine any non-trivial app not benefiting from it.

I have just two reservations: I would have thought it could be named better (OK that’s a niggle), and the customised with_scope methods it creates (e.g. with_active), should really be protected. Why? See this thread.



(edit)